My crap DCS Thread

  • My wings aren't sweeping forward for some reason. Setting the wing sweep should have been done correctly since I'm practicing using the training mission but even though they are in auto mode on the panel the wings won't do anything. I'm probably missing something, I just don't know what. Yet.

  • If you air start they should auto sweep forward at landing speed if in auto. If you started from the ramp and didn't lock the emergency handle down in the right position and press the reset button before takeoff the auto sweep will not work.

  • You can tell if DLC is on by looking back at the wing. If you see a wing slat up, it's on. If you have it mapped to a rotary the slats are controlled by that and might be up or down depending on where the dial is. Flaps must be fully extended before you can turn DLC on. If you go full power it automatically turns DLC off.

    Once I extend flaps I can't move the leading edge slats at all with the rotary knob on my throttle. Why the rotary? Everything else is full.

  • One thing I was having trouble with was seeing a lasting effect from DLC adjustments. For example my VVI (Velocity Vector Indicator) was too high, I'd extend the slats via DLC and the VVI would go down. Then I'd let go of the DLC input, returning it to center, and the VVI would creep back up. I learned that DLC really is for fine tuning your approach. You need to have a good angle of attack and descent rate for it to work as intended. Otherwise, your inputs have only very temporary affect and you really don't want to just keep holding the button down.

  • I have those two commands mapped to the switch.


    I have no idea why, but when I hit the toggle switch for wing sweep auto, the instruments show the wings in auto and swept forward to 20 degrees but when you look outside, they are fully swept back. So no DLC with wings swept back. And it doesn't seem to work after manually sweeping the wings all the way forward either.

  • I have those two commands mapped to the switch.


    I have no idea why, but when I hit the toggle switch for wing sweep auto, the instruments show the wings in auto and swept forward to 20 degrees but when you look outside, they are fully swept back. So no DLC with wings swept back. And it doesn't seem to work after manually sweeping the wings all the way forward either.

    So the solid bar in the wing sweep indicator moves all the way to the top but your wings are not forward? How about from an external view?

  • From the manual:


    Indicator detailing status of the wing-sweep system.

    Leftmost indicator pointer shows wing-sweep program position which is also the max forward angle at present airspeed and altitude.

    Middle tape shows commanded wing-sweep position.

    Rightmost tape shows actual wing-sweep position.

    The five indicator windows shows current operating mode.